Discussion:
Troubles with OPAM
(too old to reply)
Xavier Van de Woestyne
2014-10-17 16:42:35 UTC
Permalink
Hi, i'm using OPAM since 2 years.
I recently changed my distribution (now I am on Debian and XFCE).
Opam installs easily.
But on each update/upgrade try to reinstall every package. (includes
base-threads, base-unix). And when I'm trying to install, for example,
merlin, after an Eliom installation, Opam try to reinstall ocamlfind 1.5.3
but it could'nt.
Do you have any idea? (I have already try to rm -rf .opam and aptitude
purge opam to reinstall but the troubles stay).

Thanks a lot.

Xavier.
--
Xavier Van de Woestyne
***@gmail.com - TEL BE : 0474 49 53 83 | TEL FR : 06 73 38 72 84
--
Caml-list mailing list. Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs
Roberto Di Cosmo
2014-10-17 16:59:11 UTC
Permalink
Dear Xavier,
I would suggest you open a ticket on

https://github.com/ocaml/opam

providing detailed informations on a run that you consider is going
wrong (including opam version, the command line used, the CUDF dump
obtained with --cudf etc.)

As a quick suggestion, try anyhow just a simple
apt-get install aspucd
and see if anything changes.

--
Roberto
Post by Xavier Van de Woestyne
Hi, i'm using OPAM since 2 years.
I recently changed my distribution (now I am on Debian and XFCE).
Opam installs easily.
But on each update/upgrade try to reinstall every package. (includes
base-threads, base-unix). And when I'm trying to install, for example, merlin,
after an Eliom installation, Opam try to reinstall ocamlfind 1.5.3 but it
could'nt.
Do you have any idea? (I have already try to rm -rf .opam and aptitude purge
opam to reinstall but the troubles stay).
Thanks a lot.
Xavier.
--
Xavier Van de Woestyne
--
Roberto Di Cosmo

------------------------------------------------------------------
Professeur En delegation a l'INRIA
PPS E-mail: ***@dicosmo.org
Universite Paris Diderot WWW : http://www.dicosmo.org
Case 7014 Tel : ++33-(0)1-57 27 92 20
5, Rue Thomas Mann
F-75205 Paris Cedex 13 Identica: http://identi.ca/rdicosmo
FRANCE. Twitter: http://twitter.com/rdicosmo
------------------------------------------------------------------
Attachments:
MIME accepted, Word deprecated
http://www.gnu.org/philosophy/no-word-attachments.html
------------------------------------------------------------------
Office location:

Bureau 3020 (3rd floor)
Batiment Sophie Germain
Avenue de France
Metro Bibliotheque Francois Mitterrand, ligne 14/RER C
-----------------------------------------------------------------
GPG fingerprint 2931 20CE 3A5A 5390 98EC 8BFC FCCA C3BE 39CB 12D3
--
Caml-list mailing list. Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs
Török Edwin
2014-10-17 17:02:18 UTC
Permalink
Post by Xavier Van de Woestyne
Hi, i'm using OPAM since 2 years.
I recently changed my distribution (now I am on Debian and XFCE).
Opam installs easily.
But on each update/upgrade try to reinstall every package. (includes base-threads, base-unix). And when I'm trying to install, for example, merlin, after an Eliom installation, Opam try to reinstall ocamlfind 1.5.3 but it could'nt.
Do you have any idea? (I have already try to rm -rf .opam and aptitude purge opam to reinstall but the troubles stay).
I hit this bug too, some problem with newer dose used by Debian: https://github.com/ocaml/opam/issues/1683

The workaround for now is to install the beta packages which work with the newer dose:
http://software.opensuse.org/download.html?project=home:ocaml&package=opam

Hopefully once opam 1.2.0 is out of beta the official Debian package can be updated too.

Best regards,
--Edwin
--
Caml-list mailing list. Subscription management and archives:
https://sympa.inria.fr/sympa/arc/caml-list
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
Bug reports: http://caml.inria.fr/bin/caml-bugs
Loading...